just went to a website that gave me this error: “This website needs Netscape 7 to work correct

just went to a website that gave me this error: “This website needs Netscape 7 to work correctly.” Wow..that’s bad… (via @amyandrews)

Leave a Reply

Your email address will not be published. Required fields are marked *